Skydel instance crashes 1hour before last Record in Rinex GLONASS navigation file

  • GSG-842 Simulator
  • Skydel version 23.8.0

issue: Skydel instance crashes
Most probable reason: If RINEX GLONASS navigational messages file was imported into your configuration Skydel crashes with 100% repeatability 1 hour before last record in that RINEX GLONASS navigational file

Steps to reproduce:

  1. start Skydel
  2. create completely New Configuration
  3. add GLONASS G1 signal in Output 1 settings
  4. GLONASS - > General
  5. Import RINEX Navigation Message file “glonass_ephemeris_21.3.txt” from /Documents/Skydel-SDX/Templates
  6. Start time of Scenario will be changed to cover Date in RINEX file (31.03.2020)
  7. after all steps you should see
  8. last record inside Imported GLONASS RINEX is 23:45:00
  9. change Start time from 00:15:18 to 22:29:59
  10. Start scenario
  11. when Scenario time will reach 22:45:16 Skydel will crash (GUI will dissapear from screen)
  12. open again Skydel instance and Create New configuration
  13. in folder skydel/Documents/Skydel-SDX you can open “simulator.log” file and see :

As cherry on the cake:
if you have created a new Configuration and Imported Rinex GLONASS navigation file you cannot delete it from your configuration.
Clear button is not working here!!

  1. Import file
  2. Press Clear
  3. Notification will arrive, press yes

  • path to Rinex file will be empty
  • There will be NO warnign about “GLONASS satellited will be simulated …”

RINEX file still imported and notification is present.
So in this case your Skydel will crash again


Hi @kchereshnev,

Thank you for the detailed bug report, I was able to reproduce the issues and created two tickets on our side.
I will notify you when the bug fixes are available in a Skydel release.



Just foy beter tracking, i have created official ticket as well.
Case number is 00305619

1 Like

Hi @mathieu.favreau,

I was trying to simulate live sky in the skydel, unfortunately, I was not able to run GLONASS Rinex file based on the current UTC time. Which means, when I upload the recent Rinex which I have downloaded from the CDIS website, Skydel will show the below error.


Since I need to run the simulation in the current time, I was unable to run the same. Because the error says "Check simulation start date matches the RINEX File, also the simulation time must be after the record and 1h 15 before the last record. Typically, start time in UTC should be in the interval (00:15…22:30).

I tried editing the RINEX file to the current time, still the Skydel is not accepting the same.

How can I simulate GLONASS live sky in my SKYDEL?

Thank you in advance,

Hi @uxinz ,

Are you trying to simulate only for the period of the last block found on CDIS or for longer?


Hi @mathieu.favreau ,

I am trying to simulate the live sky constellations for GLONASS using the RINEX file that is available from the CDIS. When I use the file for GPS and Gallileo it works fine. But when I use the RINEX file for GLONASS I am unable to start the simulation at current time. As soon as I upload the file, the time will be automatically changed and also I can only put a time 1:15 before the last record.


Hi @uxinz,

Right now we have some limitations with GLONASS which come from the fact that GLONASS ephemeris are not Keplerian. We have work in our backlog to improve these limitations, but I can’t give a date as when it will be available.

The best you can probably do today is import the most recent GLONASS almanac and we will generate the ephemeris data during the simulation based on this almanac (don’t import any ephemeris for GLONASS). It should be quite close to the real ephemeris for short simulations.


Hi @mathieu.favreau,

Thank you for your response. Could you provide any link for downloading the almanac for GLONASS, every time I search for the same, I find an FTP link which cannot be accessible and I tried to manually edit the almanac file with the values from ([]) and it is not working as well.

Hi @uxinz,

Here is a way to get the GLONASS almanacs:

If you don’t have StudioView, download it from here (the .exe link):

Inside StudioView select Scenario editor.

In the General tab, select your date for the Start time.

Then in the Signals tab only check the L1 for GLONASS.

In the Navigation tab, select Files under Navigation Data. Click the download button and then Start.

When the download is finished, go to Documents/Orolia/GSG StudioView/Repository and look for the file named MCCT_ YYMMDD.agl.

Hope that helped,

1 Like

Hi @mathieu.favreau ,

Thank you for your valuable support. I have installed the same and downloaded the agl file. Unfortunately, when I run the Skydel simulation at current UTC time, the constellations are different.

Attaching the screenshot for your reference.

Once again, thank you for your support,

Hi @uxinz,

I just tested myself for your date and time, with Skydel’s default location as well as the almanac for that day downloaded from Studio View. I then compared with the Trimble website, the sky plot were identical:

Of course I don’t have the same location as your scenario, so the sky plot does not match with your screenshot.

Some questions I have:

  • Which Skydel version are you using
  • Is the receiver you show in your comparison receiving live sky signals
  • Can you confirm the almanac file you downloaded is named MCCT_231110.agl
  • Can you compare your receiver sky plot with Trimble’s sky plot (with same location and time)


Hi @mathieu.favreau,

Thank you for your response.

As per your questions please find the below answers.

  • Skydel version - 23.5.4

  • I am using ublox receiver EVK-M8L and I have compared the Glonass constellations with the live sky from this receiver

  • When I tested I used the file named MCCT_231010.agl

Today I tried the experiment again with the Trimble’s skyplot, however the receiver live sky polt and Trimble’s sky plot almost matches and the Glonass constellation in the Skydel doesn’t match with them. The file name of Glonass almanac for the simulation is MCCT_231015.agl

I have uploaded the almanac file in this tab which is shown below.

Please let me know if you need further clarification.

Hi @uxinz,

The file MCCT_231015.agl is for the 15 October 2023, not for 15 November 2023.
Make sure you download the file for November by validating it starts with MCCT_2311.


Hi @mathieu.favreau,

Thank you pointing out this mistake. I have downloaded the actual file and now it is working fine.

Thank you so much for your immense support in closing this issue.


1 Like

Hi @kchereshnev ,

Skydel 23.11.0 has been released with fixes to both issues you reported.


fantastic news!
will check and let you know