Error (Error) Navigation message wasn't updated for elapsed ms: 211000

I’m doing a LEO Galileo scenario that was working well until I updated skydel to 22.7.1, now after 3 minutes of the simulation, I get the following error:
Error (Error) Navigation message wasn’t updated for elapsed ms: 211000.
The error is repeatable always at that certain time of the simulation. I changed the simulation time to skip that certain time, and the simulation seems to work fine. The error happens at 08:06:XX, after dozens of seconds the simulation goes well.

You can find the file below so you can test it on your machine.


1 Like

Hi @mohdyaser

We reproduced the issue on our side, thanks for reporting the bug we are working on it.


Hello @mathieu.favreau

Any news from your side? If this is going to take long, can I downgrade my version until it is solved?

Edit: So I downgraded to 22.5.4, and now the scenario is not openable because there is a conflict in Beidou SVID36 which is not present in the previous version. I don’t want to redo the whole constellation again with a previous version, any recommendations until solving the bug?

Hi @mohdyaser,

Both bugs are high priority on our side.
The one you just found out is fixed on our side, we are currently in the process of releasing a new Skydel 22.5 version which is going to have this fix.

I’ll update you here once the new version is online (today or tomorrow).

Best regards,


Hello @mathieu.favreau

Indeed I’m using Windows 10.
If this is taking long, I would request to provide me with a licensed copy for Ubuntu until the windows bug is solved.

Hi @mohdyaser,

The Skydel release should be out today, but we had time to investigate your initial issue.

The issue is that in your scenario, the PSR of your satellites go in the negatives and Skydel doesn’t handle that.
For example, the Galileo SV 12 has a clock bias of 0.00514… which results in a PSR offset of ~-1500Km, but the altitude of that SV reaches below ~1500Km during your simulation, for a resulting PSR in the negatives.

If you enable raw logging in SettingsGlobalLoggingRaw Logging (csv) and open the log for the SV 12, you will see that the PSR Change Rate (m/s) is around -4900m/s, which is why it takes some time before the error occurs. You can also see at the end of the file, when the error occurred, that the PSR satellite time (ms) is bigger then the Elapsed Time (ms), which basically means the satellite time is in the future relative to the receiver, or in other words the satellite PSR is negative.

The workaround is to reduce the clock bias on the satellites to prevent this issue.

Hope this helped,
Best regards,