Transmission Sequence Error, Streaming Buffer Underrun

Dear @Grace and @pmleveel,

In my simulation with Skydel, GNSS Upper L-Band GPS-L1 C/A signal was generated and streaming via 10Gb Ethernet card connected to the N310 SDR. The simulation was running for about 10sec then one of below two errors occurred:

  • ‘Transmission Sequence Error: Incorrect packet detected by the radio. Please verify Network adapter’s MTU size’
  • ‘Streaming buffer underrun’

I followed guidance from Orolia Skydel User Manual to set up
+ the Jumbo packet to maximum 16348 bytes
+ Transmit Buffers to maximum 8184

But the above errors still occurred.

Could you please kindly advise me how to overcome the above problem?

Thank you very much for your guidance in advance.

Best regards,


Hi @phule,

We have received your request and will answer as soon as possible.


Thanks, Grace. Looking forward to hearing your feedback.

Best regards,

Dear Grace,

While we are waiting for your guidance of fixing the problem of “transmission sequence error and streaming buffer underrun” of Skydel program on our Windows machine, we thought these errors might not appear if we run Skydel in Linux platform. The PC machine in our ACSER lab where the Skydel was installed does have Ubuntu platform that I can install Skydel on it.

Is it possible you sent us the Skydel license file to install in our Ubuntu platform?

The serial number of our license form is 6111-0031_Eamonn_G_UNSW.lic


1 Like


First of all, we can confirm that Skydel simulation stability is better under Linux Ubuntu than Windows. The reason is that much less programs/services are running in background under Ubuntu, reducing the risk of interrupting our Skydel application.

“Buffer Underrun” errors occurs when Skydel was interrupted for too long by the O/S. To avoid this, we strongly recommend to close all other applications when running Skydel. Other Windows settings are recommended in the Skydel User Manual, section

“Transmission Sequence Error” occurs when packets are either dropped or arrive out-of-order at the N310 radio.
Most importantly

  1. Make sure you enable Jumbo packes (9014 Bytes) and Use the maximal value for “Transmit buffers”.
  2. Make sure Skydel is configured to use “Frame Size” of 8000 Bytes (Skydel Preferences, USRP tab).
    Under Ubuntu, we have the possibilty to force the Network to use only 1 “Transmit Queue”, which prevents packets to arrive out-of-order at the radio. This setting is not available under the Windows driver. I recommend to make sure you have the latest network card driver installed.

Please, let us know if this helps or if you wish to attempt using Linux Ubuntu.


Hi Serge,

Thank you very much for your very helpful guidance to fix the errors in our simulation. I have addressed them in my Network and Skydel configuration and it looks like the problem has been resolved. Haven’t received these error messages again after few hours of experiment today. Much appreciated.

Best regards,