Skydel v23.12 Error: Unable to create UHD Streamer: RuntimeError: On Node 0/DmaFIFO_0, input port 0 is already connected


We are experiencing some issues with Skydel running on Ubuntu 22.04.3 LTS with the hwe kernel 6.5.0-17-generic paired with an Nvidia RTX 4070. We have tried a couple different Nvidia driver versions all installed using the method described in the Skydel User Manual but we seem to be having different issues with each one. Currently we are using driver version 535.154.05 but after running a couple simulations we are experiencing the following error in our
simulator.log (8.5 KB)
that causes our simulation arming to fail:

2024-02-12 08:06:01.339850: Unable to create UHD Streamer: RuntimeError: On node 0/DmaFIFO_0, input port 0 is already connected.

This error has also resulted in our GPU showing Skydel taking up a lot more VRAM than normal, despite Skydel being in the Ready state:

Looking at our kernel’s ring buffer per dmesg we are also seeing the following Nvidia error:

Has anyone experienced these issues with a newer 40 series Nvidia GPU? We would appreciate any insight on what may be done to fix the instability. If there are Nvidia drivers that have been vetted by the Skydel team then we would like to use them.


Hi @grote,

I am not convinced this is an issue with the NVIDIA driver.
The error you got is related to the X300, it seems like the TX port is already used by another application.
The GPU VRAM issue could potentially be a cleanup issue on Skydel side.

I recommend restarting Skydel, power cycle your X300 and make sure no other application is connected to the X300. If we want to be convinced, maybe try to reproduce the VRAM issue with the NoneRT output.



Hey Mathieu,

I can confirm that restarting our machine and relaunching Skydel fixed the simulation arming issue so I will report back if I run into the issue again here. We are running Skydel simulations continuously so our machine should let us know pretty quick if anymore issues arise.