GSG-8 can't find its DekTec cards


we just received a GSG-8 simulator as a test device and have the problem, that when we select the DekTec DTA-2115 cards as output, we get the error message “Selected Dektec device number (0) does not exist” in the Status Log.

Is there anything we can do to solve this problem?

What we did so far:

  • Plugged in a monitor, mouse and keyboard into the GSG-8
  • Booted into the Ubuntu OS and started Skydel
  • Added a DTA-2115 as output and selected GPS L1 C/A
  • Pressed the "Arm’ Button
  • Tried a different device number for the DTA (up to 5). Did not help.


Best regards

Hi @ToppDev, please find our support team’s recommendation below:

"We suggest you to open a terminal and run:

lspci | grep -i dektec

If no text is returned by the command, this tells us none of the DekTec cards are being detected by the operating system. To try resolving, we would recommend powering down the GSG-8, flip the power supply switch to the open position, remove the five Phillips machine screws (three on top, two on the back) holding the top cover in place and open up the GSG. Each DekTec card is held in place with a single Phillips head screw at the top of the slot along with two 9/16" (21mm) nuts on the BNC connectors and a 5/16" (13mm) nut on the RF output SMA connector, both holding a star washer between the nut and chassis. Please remove the Phillips screw, nuts, and washers, then reseat the card.

Before reassembling the GSG, we would recommend powering it back on and running the lspci command again to make sure the cards are being detected."


I tried the command you proposed. As expected no output was returned, so the cards are not recognized.

Afterwards I reseated RF3 and RF4 multiple times (did not want to loosen all of the cards). But it did not help. After every reseating I tried the command again but no output.

Any other suggestions I could try?

Hi @ToppDev ,

Yes, we have another suggestion:

Please check if the Dektec Driver is active with the command:

modinfo Dta

You should see something like this:

filename: /lib/modules/5.4.0-89-generic/kernel/drivers/misc/Dta.ko
license: GPL
description: Dta Series Driver
author: DekTec Digital Video B.V.
license: GPL
license: GPL
srcversion: 2D2A50662573B5F1047A919
alias: pci:v00001A0Ed00000893sv00000000sd00000000bcsci*
alias: pci:v00001A0Ed00000886sv00000000sd00000000bcsci*

If nothing shows up, you will need to re-install the Dektec driver. Please find more info for the installation here Orolia Skydel User Manual (, see section Dektec DTA-2115B Driver.


Hello @Grace ,

we have a slightly older version of the Dta driver, but it’s loaded.

$ modinfo Dta
filename:       /lib/modules/5.4.0-84-generic/kernel/drivers/misc/Dta.ko
license:        GPL
description:    Dta Series Driver
author:         DekTec Digital Video B.V.
srcversion:     0EBD35F7C8D9A70E4DB261D
alias:          pci:v00001A0Ed00000893sv00000000sd00000000bc*sc*i*
alias:          pci:v00001A0Ed00000886sv00000000sd00000000bc*sc*i*
alias:          pci:v00001A0Ed00000884sv00000000sd00000000bc*sc*i*
alias:          pci:v00001A0Ed00005883sv00000000sd00000000bc*sc*i*
alias:          pci:v00001A0Ed00004883sv00000000sd00000000bc*sc*i*
alias:          pci:v00001A0Ed00003883sv00000000sd00000000bc*sc*i*
alias:          pci:v00001A0Ed00002883sv00000000sd00000000bc*sc*i*
alias:          pci:v00001A0Ed00001883sv00000000sd00000000bc*sc*i*
alias:          pci:v00001A0Ed00000883sv00000000sd00000000bc*sc*i*
alias:          pci:v00001A0Ed0000187Esv00000000sd00000000bc*sc*i*
alias:          pci:v00001A0Ed0000087Esv00000000sd00000000bc*sc*i*
alias:          pci:v00001A0Ed00000872sv00000000sd00000000bc*sc*i*
alias:          pci:v00001A0Ed00000870sv00000000sd00000000bc*sc*i*
alias:          pci:v00001A0Ed0000186Asv00000000sd00000000bc*sc*i*
alias:          pci:v00001A0Ed0000086Asv00000000sd00000000bc*sc*i*
alias:          pci:v00001A0Ed00000868sv00000000sd00000000bc*sc*i*
alias:          pci:v00001A0Ed00000861sv00000000sd00000000bc*sc*i*
alias:          pci:v00001A0Ed00000860sv00000000sd00000000bc*sc*i*
alias:          pci:v00001A0Ed0000085Esv00000000sd00000000bc*sc*i*
alias:          pci:v00001A0Ed0000085Bsv00000000sd00000000bc*sc*i*
alias:          pci:v00001A0Ed0000085Asv00000000sd00000000bc*sc*i*
alias:          pci:v00001A0Ed00000859sv00000000sd00000000bc*sc*i*
alias:          pci:v00001A0Ed00000858sv00000000sd00000000bc*sc*i*
alias:          pci:v00001A0Ed00000857sv00000000sd00000000bc*sc*i*
alias:          pci:v00001A0Ed00000853sv00000000sd00000000bc*sc*i*
alias:          pci:v00001A0Ed00000843sv00000000sd00000000bc*sc*i*
alias:          pci:v00001A0Ed0000083Fsv00000000sd00000000bc*sc*i*
alias:          pci:v00001A0Ed0000083Bsv00000000sd00000000bc*sc*i*
alias:          pci:v000010B5d00009056sv00001A0Esd000000A0bc*sc*i*
alias:          pci:v00001A0Ed00000091sv00000000sd00000000bc*sc*i*
alias:          pci:v000010B5d00009056sv000014B4sd0000D128bc*sc*i*
alias:          pci:v000010B5d00009056sv000014B4sd0000D118bc*sc*i*
alias:          pci:v000010B5d00009054sv000014B4sd0000D116bc*sc*i*
alias:          pci:v000010B5d00009054sv000014B4sd0000D114bc*sc*i*
alias:          pci:v000010B5d00009056sv00001A0Esd00000075bc*sc*i*
alias:          pci:v000010B5d00009056sv00001A0Esd00000074bc*sc*i*
alias:          pci:v000010B5d00009056sv00001A0Esd00000073bc*sc*i*
alias:          pci:v000010B5d00009056sv00001A0Esd00000070bc*sc*i*
alias:          pci:v000010B5d00009056sv00001A0Esd0000006Fbc*sc*i*
alias:          pci:v000010B5d00009056sv000014B4sd0000D10Abc*sc*i*
alias:          pci:v000010B5d00009056sv000014B4sd0000D107bc*sc*i*
alias:          pci:v00001A0Ed00000069sv00000000sd00000000bc*sc*i*
alias:          pci:v000010B5d00009054sv000014B4sd0000D102bc*sc*i*
alias:          pci:v000010B5d00009054sv000014B4sd0000D100bc*sc*i*
retpoline:      Y
name:           Dta
vermagic:       5.4.0-84-generic SMP mod_unload modversions 
parm:           g_DtaMaxDevices:int
parm:           g_DtaMajor:int