Error when editing the orbital parameters of BeiDou constellation

Hi there,

I’m facing an error when I edit the orbital parameters of BeiDou satellites. The error is: No i0 value for BeiDou Reserved Satellite type. I’m not sure how to solve this issue, and I would appreciate your assistance.

Kind regards,

Hi @Maria_Mohamad,

Can I know the Skydel version you are getting this error on and which BeiDou SV ID you are trying to modify?
Also did you get this error on a new config or you imported your own orbits?

Best regards,

Hi @mathieu.favreau

I’m using Skydel version 22.7.1 but I also got the same error using the previous version. I tried three different scenarios, in the first one, I modified all the editable BeiDou SV IDs (those are SV ID: 6, 7, 8, 9, 10, 11, 12, 13, 14, 16, 19, 20, 21, 22, 23, 24, 25, 26, 27, 28, 29, 30, 32, 33, 34, 35, 36, 37, 38, 39, 40, 41, 42, 43, 44, 45, 46). In the second scenario, I modified all of them except SV ID 6. In the third scenario, I modified around 6 of them, starting from SV ID 7 up to 12, and then I stopped to check whether the same error will appear again, and it appeared.

Hi @Maria_Mohamad,

Thank you for your inputs!
Indeed we are aware of this bug.

For now, the best solution might be to use the combination of GPS and Galileo constellations.
The interval of the root semi major axis (sqrt A) for GPS constellation is limited between 5147.25 m1/2 and 5159.97 m1/2 in the Skydel UI:

But you can change this value in the .sdx configuration file (e.g for GPS SV Id 1):

The new value that you have modified in the configuration file will appear in the Skydel UI when you open this configuration.